VisualAnalysis icon
Upgrade to VisualAnalysis 17.0 today. Here's why.

VisualAnalysis 12.0 Help

VisualAnalysis Tutorials: Report Customization

Project Description:

This tutorial demonstrates how custom report styles. Styles are saved reports that may be used on all your future projects.

Modeling the Project

Create a new Space Frame project.

Your model should look similar to the figure below:



Creating a New Report

Check the model for errors using the Analyze | Check Model for Errors command in the main menu. Next, analyze the structure using the Analyze | Analyze Now. Now that your model is analyzed you have the opportunity to display project information on your reports. Select the Model View tab, and then the Modify tab of the Project Manager. Under Miscellaneous, you can add a Title, Billing Reference, etc. This information will be displayed on the header of the reports you create (and visible when you view a print preview). Name your model now, and assign it a Billing Reference Number.


Now return to the Result View tab. Use the Report | Report Wizard command to begin creating a new Report. You will now be shown a dialog box in which you can choose which items you would like to add to the Report. For this example, add "Load Cases", "Member Extreme Results" and "Member Internal Forces" by selecting them in the left column and clicking "In". Once you have added these items, click "Next". This brings you to the Load Cases to Report window. Choose "Report all load cases" and select "Next". The next dialogue is the Result Cases to Report window. For this example, apply this Report Style to "All Results". Make sure that "All Results" is selected in the Report drop down menu and click "Finish". The newly created Report is now shown. Click on the Member Internal Forces table, and options will appear in the Project Manager. Select "Column Extremes" from the Results Filter to condense your report. It should look similar to the figure below:

Scroll down to view all of the results. Note in the Member Extreme Results table, the value for each result is shown along with the load case which caused that result in parentheses. You can add certain columns to your report as well. Click on the table that you would like to modify, and then select the ellipses button [] next to the line Columns in the Project Manager under the heading Table Options. On the Choose Table Columns tab, you can add or remove columns from your report. You can also modify the appearance of the columns in the report. You can set the width of each column (or row height) displayed in a table by simply Clicking on the dotted lines dividing the table cells and Dragging it to the preferred location. Several other options are available for you to customize the content and look of your report. Try a few of the different settings on your report until you are happy with the content and look of your report.

To save this Report Style so that it can be used with other Space Frame projects later, use the Report | Save Report as Style command in the main menu. Name the new style as "My Style".

This newly created Report Style will now be able to be used with future Space Frame projects. You will find this Report Style on the Command Bar when you are in the Report View tab.

Editing an Existing Report Style


Several preloaded report styles are available for your use. To use one of these styles, simply select it from the drop down menu on the Command Bar. Use the Report | Manage Report Styles in the main menu to edit any of the report styles. Select the report you would like to change, and select "Modify". Once you have modified the report to your preferences, close the Manage Report Styles dialogue. To view your changes, switch to another window (such as the Model View tab) and then switch back to Report View. You will now see your modified report style. You can also rename, or delete report styles from the Report Style Manager. Another way to load the Report Style Manager is to right click when in the Report View. This will open up a short cut menu from which you can select several options, including the Report Style Manager.

Congratulations, you have completed this tutorial and now know more about report customization!