VisualAnalysis icon
Upgrade to VisualAnalysis 17.0 today. Here's why.

VisualAnalysis 12.0 Help

VisualAnalysis Tutorials: Soil Spring Generator

Introduction:

The task at hand is to generate soil springs for the slab model of plate elements. The overall slab is 8 feet by 8 feet. It lies in the Z-X plane. It has been split into 4 plate elements in each direction.

Modeling the Plates

Rotate the grid by changing the X-orientation to 90 degrees on the Grid Tab. Change to a grid spacing of 2 ft x 2 ft., and then change the drawing mode to Draw Plates by selecting the Draw Plates button on the Tool Bar. Draw the slab as shown. Select all of the plates and change the thickness to 4" (Modify Tab | Thickness), and the material to 4000 psi concrete. (Modify Tab | Material | Name) Consult the User's Guide or the appropriate tutorial if you need help drawing plate elements.

Soil Spring Generator

Once you have created the slab, select the Model | Soil Spring Generator Menu item to start the Soil Spring Generator Tool. Once the tool has started up, you are prompted to select the plates the spring supports need to be applied to. Select all of the plates in the slab.

The next step is to specify some soil parameters. Enter a value of 150 lb/in3 for the Subgrade Modulus. You are also asked to specify which z-face the soil is in contact with. This refers to the local z-axis of the plate elements the soil springs are being applied to. Choosing the proper z-face for the soil is a very important step. The soil spring generator creates compression only springs and if they are applied to the wrong face they won't provide the model with support in the proper direction. If you aren't sure which direction is the +z or |z direction for the plate elements, you can toggle on the display of the plate local axes using the Filter tab of the Project Manager.
Select the proper z-face for the model you created and click Finish to complete the spring generation.

Analyze the Structure

Now apply an area load of 100 psf to the slab in the dead load service case (D). Constrain the system by preventing the displacement of any single node in the X & Z direction and Y rotation. Check your model for errors, and analyze the structure. If there are problems, try supporting more nodes with the same constraints. In the Filter Tab of the Project Manager model check the box for "Displaced" and select "dz" in the Plate Results field. The displaced model should look something like one shown below. (The displacement shown below is magnified with a factor of 0.5 (Filter Tab | Results Display | Displaced Factor):