VisualAnalysis icon
Upgrade to VisualAnalysis 17.0 today. Here's why.

VisualAnalysis 12.0 Help

VisualAnalysis Tutorials: Plate Meshing

Project Description:

In this tutorial we will create the two hydraulic tanks below to illustrate proper modeling techniques associated with using manual plate elements. This tutorial describes the classic method of creating plates and meshing them. Beginning with VisualAnalysis 7.0 and newer versions, Areas can also be used to create "managed' plate elements and automatically generate meshes without having to worry about plate element continuity through common nodes as described in this tutorial. See VisualAnalysis Help | Contents for more information on Automatic Meshed Plates.

Rectangular Hydraulic Tank

The dimensions of the rectangular tank are 40' long, 20' wide, and 20' tall. The walls and base are composed of 24" thick concrete having a compressive strength of 4000 psi. The base also has a footprint 4' longer and 4' wider than the walls.

Draw a plate element on the default grid in the XY direction that is 40' long and 20' tall.

Select the plate element and go to Model | Generate Copies. Use a rectangular pattern to generate one copy in the Z direction spaced at 20'.

Turn off the default grid under the Grid tab of the Project Manager by clicking on the "Shown" box. Your model should appear as shown on the right.

Now draw the remaining walls of the tank at the ends of the existing plates.

Select all four plates and under the Project Manager, change their material type to 4000 psi concrete and their thickness to 24". Your model should appear as seen on the right.

To draw the tank base we will have to move our default grid to the XZ plane.

Turn the grid on under the Grid tab. Change the grid's orientation 90 degrees about the X-axis.

Rotate the model so you are looking at a Bottom Plan view. You may now draw in the tank bottom | 2' wider than the walls on each side.

Under the Project Manager, change its material type to 4000 psi concrete and its thickness to 24". Your model should appear as seen on the right.

Meshing the Plates:

Forces may only be transmitted between plates at common nodes. Below are two different examples plate meshes, created manually.

The meshing on the left will not provide accurate results of the models true behavior. Notice that forces experienced by the two different colors of plates are only transmitted at the top and bottom N2 and N6 nodes. The meshing on the right is a better choice. Forces experienced by the two different colors of plates are transmitted at the top and bottom N14 and N20nodes as well as the two intermediate N15 and N18 nodes.

Meshing Size:

Finer meshes will yield results that are more accurate, however they can greatly increase the models analysis time. Below is an example of a plate that is uniformly loaded and pinned at the corners. The results shown are the deflection of the plate with increasing mesh refinement.

2 Plates 4 Plates 16 Plates

0.6981" 1.2909" 1.6246"

64 Plates 256 Plates 1024 Plates

1.6338" 1.6538" 1.6595"

Notice that it does not take a great amount of mesh refinement to accurately portray the plate behavior.

We are now ready to mesh our hydraulic tank by splitting our previously drawn plates. Plates are split according to their local axes which vary according to how they were drawn. We will split our plates into 2' square elements.

Under the Filter tab, select the "Local Axes" feature under Plate Details.

Now select the two longer walls and right-click. Choose Split Plates.

In the next dialog box the plate can be split into parts oriented about its local axes. Split the plates into 20 parts along their length and 10 parts along their height.

Repeat the process for the two shorter walls, splitting the plates into 10 parts along their length and 10 parts along their height.

The same size 2' square mesh can now be applied to the tank bottom, splitting the plate into 22 parts along its length and 12 parts along its width.

Note: There may be a maximum number of parts that an element can be split into. In this case, you may have to be clever and split the larger element into a handful of smaller elements which then can be split to fit your mesh.

When you are finished meshing the rectangular tank, it should appear as shown in the picture below. Notice that where walls intersect or meet the floor, all meshes share common nodes.

Cylindrical Hydraulic Tank

The cylindrical hydraulic tank is 80' in diameter and 20' tall. It consists of 14" thick elements of 4000psi concrete.

Create a new project. We will begin by setting up our polar grid.

Under the Grids tab click on the "Add or Remove" ellipsis button.

Select a polar grid type from the "Add New Grid" drop menu and close the Grid Manager.

Hide the Default Grid and Show the new Polar Grid.

Enter a Z-spacing of 10', an R-spacing of 40', the number of Z-Points as 2, and the number of R-Points as 1.

Enter the number of Sectors as 100 and orient the graph at 90 degrees to the x-axis.

Draw one plate into the grid and split it ten times along its height.

Hold down the Shift key and click on one of the plates to select them all.

Go to Model | Generate Copies. Use a circular pattern. Copies will be rotated about the y-axis with a center point of (0, 0, 0). To complete the tank, 99 copies need to be made with 360 degree total angle of rotation.

An area will be used to create the mesh for the tank bottom. Drawing an area by hand across 100 bordering nodes however is tedious and time consuming. To aide in this situation, VisualAnalysis has "Create Areas Automatically" and "Create Area through Selected" features located in the Model menu.

Go to Model | Create Areas Automatically. Select the "Generate Areas for the exterior of the structure." Option and click OK.

Filter the model so only Areas are visible. Orient the model to the Front view and Select all the areas created above the base and delete them for now.

Orient the view type to a Bottom view and select the area.

In the Modify tab, turn on the Auto. Generate in the Meshing section.

Change the Mesh Thickness to 14" and the Mesh Material to 4000 psi concrete.

Under the Filter tab of the Project Manager, click to make the Nodes "Hidden."

Select all of the plates by holding down the Shift key and clicking on a plate.

Under the Modify tab of the Project Manager you may now change all plate thicknesses to 14 in and the material type to 4000 psi concrete. When you are finished your model should similar to the picture below.