VisualAnalysis icon
Upgrade to VisualAnalysis 17.0 today. Here's why.

VisualAnalysis 12.0 Help

VisualAnalysis Tutorials: Braced Frame

Project Description:


This example will use the following frame to model lateral wind loading, patterned live loading, and temperature loading. Additionally, moment releases will be required on the cross bracing. We will create a model similar to the one shown above:

Setting up the Project

To start a new project, save your current project, and select File | New. Another option is to enable the VisualAnalysis Startup Wizard. You can do this under Edit | Preferences. You will find it on the Desktop tab under "Startup Project". If selected, each time you start up VA you will be presented with the VisualAnalysis Quick Start Wizard. Choose "Start a New project" and select Start!. For this tutorial select  Plane Frame for the Structure Type under Modify Tab | Project | Structure Type. Set the unit style to US "lb-Ft" under Edit | Project Units. Name your project "Braced Frame" on the Modify Tab | Miscellaneous | Title.

Modeling the Structure

To begin, draw a 32 ft column member and specify it as a W12x87. Note you may have to zoom out so that you can draw the full 32 ft. This is easily done by rolling your mouse wheel or using the menu commands. Select this column and use Model | Generate Copies. Choose a "Rectangular Pattern" and generate 3 copies in the X direction spaced at 20 ft.

Since the middle bay of the model you will build is spaced at 15 ft, use the move command to correct your model. Select the two right most columns and choose Model | Move.  Move Selected Items 5 ft in the -X direction.

Now draw in the top-level beams using click + drag. Select these and specify W14x30 under Modify Tab | Shape | Type. You can select multiple items by holding down the Ctrl key while clicking on them. Select the top-level beams and use the Generate Copies command in the Model Menu to make two copies in the Y direction at 10 ft. Note that the negative sign has the effect of moving in the Y direction, and that generated copies are automatically split and connected to preexisting columns. When you finish, the model should look like the picture seen below. You can adjust what information is displayed in the Model View by selecting the desired tags on the Filter Tab.

Final Model Geometry

 
We now need to add L3-1/2x3-1/2x3/8 cross members to the middle bay. When you draw members that cross, VA will automatically split and connect them. This is one of the few cases where we do not want the X-bracing connected because we do not expect any force transfer to exist between the brace members. In order to stop VA from splitting and connecting the X-bracing, draw the members using Alt + click + drag. We also need to be sure to release the moments on these members. To do this, select the members and under Modify Tab | Connections | Type, change the selection to "Simple Connect". A frame structure, as we selected at the beginning, assumes by default that all of the connections are moment connections. When this is not the case, the moment must be "released" so that it behaves simply connected. Lastly, fix the column base supports by selecting "Fixed" under Modify Tab | Support | Type. The final model should appear as seen above.

Loading the Structure

For this model we will be applying loads in the following service load cases: Dead Loads, Live Loads Pattern 1, Live Loads Pattern 2, Wind Loads, and Temperature Loads. Loads need to be applied to the structure within the corresponding service load case. This is done by selecting a particular load case from the drop down menu on the Status Bar. The displayed service load case is the one in which the loads are applied.

Dead Load Service Case

We want to apply a 500 lb/ft uniform load in the global -Y direction to all the beams. Make sure the Dead Loads service case is selected in the Status Bar at the top.

On the Filter Tab of the Project Manager, under Member Details, locate the Name Filter field and type in "BmX" and press Enter. This will isolate all elements based on the specified convention. Select all of the beams with Shift + click (and click on any one of the beams). Choose Load | New Member Loads. A dialogue box will appear requiring several selections. For Member Load Type, specify "Uniformly Distributed" and for Global direction, "Force Y". Specify the load as 500 lb/ft in the Load Magnitude box and click "OK". (A minus sign indicates the negative direction of that specified. i.e. Force -Y)

Live Loads Pattern 1 Service Case

To specify a specific live load pattern, choose Load | Load Case Manager and click on the Service Cases Tab. At the bottom click "Create". Here label your service case "Live Loads Pattern 1" and select the source of the loads as Live. When you are finished amending your service case, click "OK". We now want to apply a -2000 lb/ft live load in a similar manner as demonstrated above. Switch the service case to "Live Loads Pattern 1" in the Status Bar. With the BmX name filter still on, select the members as shown below and apply the -2000 lb/ft load.

Live Load Pattern 1 loading with the BmX name filter on.

Live Loads Pattern 2 Service Case

Similar to the procedure found for Live Loads Pattern 1, apply a -2000 lb/ft load to the beams shown below for Live Loads Pattern 2. Switch to the Live Loads Pattern 2 service case in the Status Bar drop down menu. Instead of using the Load Menu, after selecting the desired members, right click and choose "Apply Member Loads" from the Context Menu that appears.

Live Load Pattern 2 loading with the BmX name filter on.

Wind Loads Service Case

We now want to apply our wind load to the left column. Remove "BmX" from the Name Filter field with Delete, and hit the Enter key. You should now see all of your structure again. The wind load is to be a linearly distributed load varying from 0 lb/ft at the base to 160 lb/ft at the top of the column. To apply this over numerous members the load needs to be specified for each of the three column segments. Switch to the Wind Loads service case (W+X) in the Status Bar.

Select the bottom column and click the "Apply Member Loads" button on the Tool Bar. Select "Linearly Distributed" and change the direction to Global Force X. Specify the magnitudes as 0 lb/ft to 60 lb/ft. (160 lb/ft / 32 ft = 5 lb/ft per foot of column.) Select the middle column and apply the wind load this time ranging from 60 lb/ft to 110 lb/ft. Lastly, select the top column and apply the wind load ranging from 110 lb/ft to 160 lb/ft. Your model should look similar to the picture on the right.

Temperature Load Service Case

For this tutorial we will say that some kind of temperature differential is taking place in the exterior columns. Switch to the Temperature Loads service case (T) and apply a 5 deg-F/ft temperature gradient to the exterior columns. Select the exterior columns, and apply a member load using Load | New Member Loads. Select "Gradient Temperature" and "5 deg-F/ft" for Member Load Type, and Temperature Gradient. See the picture below:

Temperature Gradient of 5 deg-F/ft applied to exterior columns.

Analysis & Results

To analyze your model, you need to select a series of load combinations to be used. Click the Load Case Manager button on the Tool Bar. In the Load Combinations tab, select "ASCE 7-05 LRFD". Next, check your model for errors. Select Analyze | Check Model for Errors. If something looks like a potential problem, it will direct you to where to start looking.

Once we have a good model, we should set our analysis options. Go to Analyze | Advanced Analysis Options and make sure the "Calculate dynamic mode shapes" box is unchecked (See Dynamic Analysis in the User's Guide for a description about this feature, and when you might want to use it). The Static Analysis setting is located in the Project Manager of the Design View, Modify Tab | Analysis. Preform a 2nd order analysis by selecting "P-Delta". Now select Analyze | Analyze Now or click the Lightning Bolt button on the toolbar. You should now see the deflected shape of your model in the Result View Tab. The deflected shape of the model can be viewed under any of the service or load cases found in the Load Case Manager. Try viewing a few different Result Views by switching the service/load case in the "Load Case or Result Case" drop down menu found on the Status Bar.

Deflected shape Load Case: 1.2D+1.6W+L+0.5Lr >> +X

Note that the deflected shape shown is amplified, and may not be what you expect. The shape amplification factor is located on the Filter Tab of the Project Manager under Displaced | Factor. With a setting of zero, the actual relative displacements will be shown. The default setting is 0.1. Sometimes the amplification makes the deflected shape look strange. An example of this is in the dead load case, the cross bracing looks like it has deflected a significant amount, but when checked, its deflection it is on the order of 0.2 inches.

Similar to checking our model for errors before analyzing, we should also validate our analysis results before reporting and working with our results. Using Analyze | Result Validation Checks to check the results is a good place to start.

The Result Validation Checks looks at translations in the model to verify that the small deflections assumed in a linear analysis are not violated. The validation checks also audit the applied loads and reactions to make sure the statics balance. Lastly, the report performs simple material strength checks (not code checks).


There are a number of ways to view results for the various load cases. In the 2D Tutorial we looked at some graphical reports. The Report Menu has several options available for reporting. From the Results View tab, with load case 1.2D+1.6W+L+0.5Lr >> +X selected, select the top left beam, right-click and choose "Member Graph" from the context menu. This will display several member graphs. In this case deflection, shear and moment graphs are shown. You can change what type of graph is displayed on the Filter Tab of the Project Manager.

Member Graph for the top left beam, Load Case: 1.2D+1.6W+L+0.5Lr >> +X.

Switch back to the Results View tab. Select a member and try a few of the options available on the context menu that appears when you right click. Try the Report Selected Member option. Next try the Animate Results View option. These features will benefit you in different ways; some yield pertinent design information, while others will help you visualize how your model behaves when loaded under different loading combinations.

Congratulations! You have now completed this tutorial.