VisualAnalysis icon
Upgrade to VisualAnalysis 17.0 today. Here's why.

VisualAnalysis 12.0 Help

VisualAnalysis Tutorials: 3D Modeling

Project Description:

This project will demonstrate and discuss some of the methods to create a model in three dimensions. Our objective will be to create a space frame using various methods. We will incorporate several of the time saving features found in Visual Analysis.

Setting Up the Project

Start a new model by selecting File | New. For a 3D model, we want to use a "Space Frame". Select this now from the Modify Tab | Structure Type. Now under Edit | Project Units, set the unit style to "Pounds & Feet". Next, on the Modify Tab | Title name the project "Modeling in 3D". This will display the project name on project reports.

Modeling the Structure

Generate Standard:

One of the simplest methods of quickly generating models in three dimensions is to use the Parametric Structures found in the "Create" Tab of the Project. Select the Create Tab and the following options will appear as shown in the picture below. There are several categories available for generating models. Click on the [+] plus sign next to "Frames" to expand the frames section. Select "Moment Frame (Unbraced)" by double-clicking or click+draging into the anywhere in the workspace. In the "Origin" dialogue box that appears, the origin may be left at the default location (0ft, 0ft, 0ft), and the model need not be rotated about any axis (Leave @ 0 degrees). Clicking "Next" will bring up the Dimensions dialog box. Set the "Story Height, H" to 15 ft; set the "X bay spacing, L" to 20 ft; and set the "Y frame spacing, Z" to 20 ft. Select "Next". On the following page enter 2 for "Bays, M"; 2 for "Stories, N"; and 2 for "Perpendicular Bays, O". Clicking "Finish" will complete the Generate Standard Wizard. Your model will now be generated. Several methods will allow you to view the model from different aspects:

Ctrl + keyboard arrow will "nudge" or rotate the model in small increments.

Ctrl + Drag Wheel Mouse rotates your view in the direction of mouse movement.

Click on a corner or face of the "Cube" found in the lower left hand corner of the workspace to rotate the model to preset viewing orientations (These are also found in a drop down menu on the Command Bar).

The generated model should look similar to the one pictured. (Your model may show a grid, node labels, member labels, etc., depending on the settings specified in the Filter Tab of the Project Manager.)

You can also select from a number of predefined views using the "Quick View" drop down menu found on the Command Bar.

To analyze your model, you will need to complete the following steps:

Create the structure supports. Select the nodes at the base of the lower floor columns using Ctrl + Click. Go to the Modify Tab | Type: Select "Fixed" supports.

Make or change your member type by selecting all the members using Shift + Click on any member. This will highlight all similar members. On the Modify Tab change your selected members to W14x53. Note the Material type found below the Shape Name. In this case, the material should be ASTM A992 Grade 50. For some predefined shapes, you will have to select the appropriate material type. Always verify that the material selection is correct.

Apply loads to your model. There are a variety of different ways to apply loads to your model. These can be found under Help | Quick Start Tutorials in the "Load" folder.

The Generate Standard library found in the Create Tab contains many truss configurations, plate & tank models, and other convenient models that you may find useful. You have the ability to edit the Generate Standard text file allowing you to create your own Generate Standard models. If there are structures you work with frequently, you can greatly increase your productivity by modifying the Generate Standard text file and adding your structure.

Starting in Two Dimensions:

Another common way to model in three dimensions is to start in two dimensions and make copies in the third dimension. Save your current model if desired, and start a new project. Select the "Set Drawing Mode: Draw Members" button on the Tool Bar. On the Grid Tab of the Project Manager, adjust your grid settings as desired, and draw a column 30 ft high. Select the column and make two copies in the X direction spaced at 20 ft apart using Model | Generate Copies. Specify a rectangular pattern in the dialogue box and click "Next".

Enter the number of copies and spacing in the appropriate boxes. Your columns should look similar to the picture shown above.

Draw a beams at the Y = 30ft level using click + drag between two nodes. If you draw the beam from the leftmost member, COL1, to the rightmost member, COL1-1, the beam will automatically be split as it crosses the middle member, COL1-0.

Next, draw the beams in at the Y = 15ft level. At this point, with the grid and member names shown, the frame should look similar to the one shown below. To turn on the member names, select the check box under Filter | Member Details | Name in the Project Manager.

Select the entire frame using the "Shift" key and use Model | Generate Copies to make two copies in the Z direction spaced at 20ft.

Now sketch beams in between the frames to make a model similar to the first model you created from the Generate Standard Library.

Manually Sketching:

Save your current project if desired and start a new project. Following the steps described in the "Sketching in Two Dimensions" section above, start drawing the same 2D frame in the XY plane.

Once your frame is drawn, use the "Cube" or the "+Y Rotate" button on the Tool Bar to view the right side of the model. You should now be looking at the right end of the frame you just sketched. To rotate the grid, change the Y-Orientation of the grid to 90 degrees (Found on the Grid Tab). You could continue to draw in this fashion or use the Generate Copies function to save time.

Another method of copying is to copy in a circular pattern. This can be used to form an array of elements. Try this by selecting all of the members using shift + Drag. Next, select Model | Generate Copies (Or used the shortcut key ctrl+b). Choose "Using a Circular Pattern" from the dialogue box and click "Next". Next choose to "Rotate parallel to: The Y-axis" with your "Center of Rotation: Node 6" and click "Next". Enter 90 degrees under "Spacing between copies" and make 1 copy. Your model should now look something like that shown in the picture below, depending on the model orientation.

There are many ways of creating three dimensional models using components of simpler two dimensional models. Symmetry and the complexity of the structure will dictate how much of the structure can be created using copies of components found in the Generate Standard library versus how much must be manually. Often times a complex structure can first be generated as a simple repetitive model, and then modified and detailed by deleting and adding unique elements.

You have now successfully created 3D models using a variety of different methods. This marks the end of this tutorial.