VisualAnalysis icon
Upgrade to VisualAnalysis 17.0 today. Here's why.

VisualAnalysis 12.0 Help

VisualAnalysis Tutorials: 2D Modeling, Part 1

Project Description:

This "getting started" tutorial demonstrates some basic features of VisualAnalysis (VA). In Part 1, you will set up your project, and create a model of a two-dimensional steel moment frame with a curved glue-laminated member. In Part 2 you will load, analyze, create a report, and view member graphs.

Model1Note: You may wish to spend a few minutes in the "Essentials" chapter of the Help file (User's Guide) before working this tutorial so that you are familiar with our terminology.

Version Note: This tutorial was created using a prior version of VisualAnalysis. Minor changes to the software may have occurred including new features and graphics updates. The appearance of dialog boxes and the Project Manager may be altered slightly. () or the User's Guide () if steps do not appear correct.

Setting up the Project

Launch VisualAnalysis from the Desktop icon or using the Start | All Programs | IES | VisualAnalysis

When VA is first started, you are presented with the VisualAnalysis Startup Wizard. Choose the "Start a New project" radio button. Choose "Plane Frame" from the drop down menu and click the Start! button.

In the Project Manager, take a moment to customize your project. In the Miscellaneous field, you will find input boxes for project Title, Billing References, and Notes. For the Title of this project enter "2D Modeling". Enter "#1234" as the Billing Reference. These will appear on the reports you create, and can be displayed in the Model Window by selecting the check box under the Filter Tab | Window Options in the Project Manager.

Now set the units for your project. Unit adjustments can be made in the drop-down box above the model view. Next, save the file with File | Save. Name the file "2D Modeling.vap" and choose a location for your project file.

Next, save the file with File | Save. Name the file "2D Modeling.vap" and choose a location for your project file.

Setting up a Coordinate Grid

A grid system will help you to draw your model quickly. To do this first click the "Grid" tab in the Project Manager. For this project let us create our own grid system. Double click the [] box to load the Grid Manager.

In the Grid Manager click on the Add a New Grid pull down arrow and select "Front View (XY)" and close the dialog. Now, check the appropriate boxes to hide the default grid and show the XY Plane Grid in Project Manager  Visibility. In Project Manager  Edit Grid, select "Front View (XY) N" from the drop down list (an arbitrary number will appear for N).

Once selected, the grid properties can now be edited. You can specify the coordinates where the grid origin is located, grid orientation (usually needed only in 3D modeling), the number of grid points, and grid spacing. Change the Grid Extents to 82 X-points and 82 Y-points. Leave the remaining default settings the same.

Modeling the Structure

Before you begin to draw members you may want to adjust the zoom in order to be able to draw the full length of the member on the screen. Use your mouse wheel (depending on your computer's mouse properties) to scroll out or use the Zoom Out button to adjust the coordinate system until you are able to draw the entire member. The coordinate display, located in the lower right corner of the VisualAnalysis Status bar, will help you determine if you have enough space to draw the column. It shows the current position of the mouse cursor with respect to the global XY axes. Notice that as you move your mouse cursor over the model window, the coordinates change accordingly.

This display can help you properly position members. As you draw a member, the coordinate display changes to show the position of the cursor relative to the member start point. This feature is helpful for ensuring proper member length and orientation. You can also pan while drawing members by click mouse wheel + drag (while holding down the primary mouse button). As you drag the mouse you are only allowed to begin and end members at points on the grid (or existing nodes). It will frequently happen that a given project will require a grid spacing or coordinate system different from the default setting. In this occurrence the grid can be reconfigured in the Grid Manager.


Notice also that as you drag the cursor a small picture of a member accompanies it. This is VA's way of confirming that you are drawing a member (as opposed to a plate or some other element).

We are now ready to begin drawing our structure and will start with the column on the left side. Move your mouse cursor over the point (0,0). Depress the left mouse button and drag the cursor to the location of the second end of the member (0,42). Release the left mouse button and the new member will appear with nodes at the two ends. (Note that the member is "selected' after it has been drawn.

Options to edit the member are presented in the Project Manager under the "Modify" tab. (If the Project Manager is not showing on the left side of your screen, press F2 or select View | Toggle Project Manager). Select the member you just created by clicking on it once. Members that are selected will be highlighted. Under the Shape sub-heading in the Source input box, select "Database Shape" from the drop down list. Now we will select one of the available Database shapes. Double-Click the [] button directly below and the Choose Shape dialog will appear. Under AISC Shapes and W, select a W12x79. A default material is associated with each shape. For example, the default material for an AISC W shape is A992 Gr. 50 steel. If this is not the correct material for your shape, you may choose a different material under the Material section of the Modify tab. Let's assume that you are using an older W Shape that is made of A36 steel. Double-Click the [] button to bring up the Choose material dialog. Select "ASTM A36" under Steel and choose "OK".



With the column member still selected, we will use Model | Generate Copies or (Ctrl + B) to create two more columns. In the Generate Copies: Pattern dialog, use a Rectangular Pattern. Make one copy in the x-direction at 30ft and then repeat the process for another column at 55ft. Next, if the grid is currently visible, turn off the grid by going to the Grid tab of the Project Manager and un-checking the "Shown" box under the Visibility field.

Add or remove from the selection by holding the Ctrl key when you Click.  Use Shift+Click to select all the visible items of the same type.  Use Shift+Drag with your mouse to define a "selection box'.  Use Shift+Ctrl+Click to select all items of a type, with similar names (e.g Bm1, Bm2, Bm3, but not Col1). You may also select multiple items using lists in the Find Tool. ">To view members as they appear in the "real world", you can select "Picture View" under Quick Views. This is located in the drop-down box above the model view, next to the unit adjustment drop-down box.

Use the "Cube" in the lower left corner to rotate your model to obtain the view you want. You can also set up your mouse roller + Ctrl key to rotate the model or hold down the Ctrl + arrow keys to "nudge" the model. You may also use the mouse wheel to zoom and pan the model. You will find the available methods to customize your mouse in the User's Guide.

Now we want to draw the beams to complete our frame. Draw in the upper girder between the top nodes of the outside columns. This member will cross the node at the top of the middle column. The member will be connected to the column at the node. When drawing members that cross nodes or other members, VA will connect the member at a node, but will automatically "Combine" the portions on either side of the node. (If crossing a member, a node will automatically be created at the intersection). This helps to keep models simple by having fewer members. Now uncheck the box found under Filter Tab  Window Options  Picture View. You will now notice in your model view that the combined member (the beam) is shown with a heavier line than the columns. Take a moment now to consult the User's Guide and read the section on Combined Members to get a brief description of when this feature is useful. (User's Guide - Model  Member Elements). You can be prompted on how to direct VA to handle this type of situation when drawing members. Select Edit | Preferences | Desktop. Check the box "Always ask to split or combine members when drawing". Now, delete the member you just drew, and redraw it in the same manner. In the dialog that appears, select "Split existing member to make the connections" followed by Ok. Two separate members are now drawn. Edit the girders, making them W24x68 shapes composed of A36 steel material, using the Modify tab of the Project Manager. Select both roof girders and choose Model | Generate Copies. As before, use a rectangular pattern and make 2 copies in
the y direction at -14 ft.

Text Box: Tip:  VisualAnalysis has a very useful Find Tool at the bottom of the drawing.  This feature allows you to quickly sort through members, nodes, plates, load cases, and more.  If this feature is not shown, you can toggle it on and off by choosing View | Toggle Find Tool.  From a report, if there is a critical member or node you are interested in, you can quickly find it in the model with this tool.

Next, let's set up a grid to draw a curved member. In the Project Manager, under the Grid tab - Grid Manager double click the [] button next to "Add or Remove". From the popup dialog that appears, select "Polar" from the drop down menu. Check the box for Polar Grid under the Visibility tab. Now modify the grid settings in the Project Manager under Spacing.


Set the X-Location to 55ft (the right support location). Leave the Y-Location set at 0 ft. Set the number of Sectors to 40 and the R-spacing to 14 ft.

Draw a curved member as shown below using the intermediate grid points. (It might be helpful to zoom in before attempting to draw the curved segments.) Select all of the segments and change the shape to be a Western Species GL3.125x22.5 (under NDS Wood) and the material to Softwood Glulam\Primary Bending\16F-1.3E. Now, with all of the segments still selected, name them with the prefix CURV using the Model | Rename feature. Using the Grid Tab, turn off the grid. If member names and properties are labeled, use the Filter Tab to hide names and properties. The structure should look like the picture below:

Now we must support the structure from moving in our model space. Select the lower nodes and make them "Pinned" supports by selecting this option from the Support Type drop down box under the Modify tab of the Project Manager.

The curved glulam beam is presently modeled as being connected to the steel frame by a rigid connection (the default connection type when members share a node). This is not typically a real world situation. To change this, the strong axis moment should be "released" near the node where the glulam member connects to the steel frame. End releases are shown as small circles at the end of the member that is released when the member is selected. The Node 1 and Node 2 designation, found in the Project Manager is determined by the direction that the members were drawn. To get a better view of the nodes, uncheck the box beside "Picture View" on the Filter Tab  Window Options. Select the glulam member connected to the steel frame. Under the Modify tab of the Project Manager, change the connection type to "Simple-Rigid".

Member with end-moment released

This marks the end of this tutorial, 2D Modeling - Part 1. When you are ready to continue, grab a cup of coffee and continue on to Part 2 where you will load, analyze, and create reports for your model.