VisualAnalysis icon
Upgrade to VisualAnalysis 17.0 today. Here's why.

VisualAnalysis 12.0 Help

VisualAnalysis Tutorials: ACI Concrete Column Design

Project Description:

This example will use the column shown below to illustrate the process of designing a concrete column using VisualAnalysis. In a real life situation, the column below would probably be part of a frame, but for this example, the model will consist of a single column.

Building the Model

The model consists of a 120" long, 12"x 12" concrete (f'c = 4000 psi) column. The column is fixed at its base and free at its top. Sketch in a member, and then select the member, and on the Modify Tab under the Shape heading, select "Standard Parametric" from the drop down menu next to the Source heading. Use the ellipsis button [...] to bring up the Parametric Shape Dialog. Don't forget to specify the proper material. Next, fix the base by selecting the node and specifying the Support on the Modify Tab. If you need help creating the model please consult the VisualAnalysis User's Guide (Help | Contents).

Loading

Apply the following forces in the Dead Load service case: Force-Y of -50 kips and Force-X of 5 kips at the top of the member (select the node, right click, "apply nodal load". Also, select "Don't add the structure weight to this load case" using the Edit Load Case Toolbar Button. This can be useful when validating analysis results.

Now, select ASCE 7-10 LRFD load combinations from the Load Case Manager (Load | Load Case Manager) to include these combinations in the analysis.

Information on applying loads is available in the VisualAnalysis User's Guide (Help | Contents).


Design Group Parameters

Switch to the Design View. VisualAnalysis automatically creates design groups for you. The design parameters are controlled completely through the Project Manager. Select the member in the design view and click on the Modify tab of the Project Manager to begin editing the design parameters.

Concrete Parameters:

The "Concrete" parameters are the first parameters available for editing in the Project Manager. For this example, leave these unchanged. Leave the High Seismic Risk option unchecked.

Design Parameters:

These inputs allow you to limit sizes and increments used in sizes generated by the design software. Set the increment to 2 in. These settings let the design software know that you want it to work through cross sections two inches at a time (i.e. Try a 12"x12"; then a 12"x14"; then 14"x12"; then a 14"x14"; then a 14"x16").

Column Options:

The "Column Options" parameters are next in the Modify tab. The column will be designed as a rectangular section with bars on 2 faces. Specify "Square 2 Face" for the rebar pattern. Make sure F'c is set to 4000 psi (you must change this setting while in the Model View). Set the cover to 1.5 in. Also make sure the Reinforcing Steel Fy values are both set to 60000 psi. Set the Tie Bar Size to #4's.

Column Parameters:

The Column parameters provide the design software with information about the overall frames in which the columns in the design group belong to. It should be noted that even if the model is only two dimensional, the frame parameters are set up for three dimensions. They are intentionally set up this way so that weak axis buckling is not forgotten.

In the Model View, turn the Local Axes filter on (Filter Tab, Member Details) to determine their orientation.

K Factors:

Back in the Design View, the Ky value refers to the effective length factor for buckling in a plane created by the member's local x-axis and local z-axis. The Ky value is used to calculate the slenderness ratio ky*ly/ry (similar for the Kz factor).

The default for the k factors is to let the software calculate them automatically using the procedures of Chapter 10 of ACI 318-05. This procedure utilizes the relative rigidity of members framing into a joint and the nodal support conditions to calculate the effective length factors. In this example we have removed the member from the frame it belonged to. This means the effective length factors may not be calculated properly by default. With this in mind, we will need to override the k factors. Check the Manual Kz and Manual Ky options. Edit boxes appear allowing you to specify k factors. Enter 1.25 for the Ky & Kz values. Leave the Moment Magnification z and y values at 1. Please note that we are using k-factors greater than 1 (generally corresponding to one end exhibiting lateral translation) but we are not checking the Sidesway option. Please consult the User's Guide for more information about when it might be appropriate to use moment magnifiers, as well as the sidesway options.

Analyzing the Structure

The design process cannot take place until the model has been analyzed. For this example let's use First Order Analysis Results (Modify Tab of the Project Manager while in the Model View screen). Analyze using the Analyze | Analyze Now menu item

Designing the Member

Once the analysis is complete, select the Design View tab. Design checks are performed using the specified member size. VisualAnalysis will attempt to find a reinforcement pattern and the given cross section dimensions. In this case, our member is insufficient with the default reinforcement (Unity Value of 1.39). We may still be able to achieve the required strength by increasing the reinforcement. If you would like to adjust the reinforcement sizes used in the design, click on the ellipses button [] next to the "Adjust Rebar" item on the Modify Tab. Once the rebar is modified to your preference, select "OK". Your unity check may or may not be affected (in this case, increasing the rebar to 4-#8's drops the unity value to 0.99)

Now, it may be of use to allow the design software to select a section that will meet strength requirements rather than using a trial and error iterative process. Choose Design | Design Selected Group (or select the ellipsis button [...] next to "Design Selection:" in the Modify Tab). This will pop up the Concrete Column Design Selection dialog. Here you can make a selection if one of these meets your requirements. Select the 14" column for this example.

Synchronizing Design Changes

After accepting the design, the unity value that appears in the design view should have a ~ in front of it indicating that it is a preliminary value based on the analysis results with the original 12"x12" member in place. To get the updated (actual) unity value you must synchronize the design changes.

To synchronize the design changes, select Design | Synchronize Design Changes. Next, you will be prompted to re-analyze, select "Yes", and when it finishes re-analyzing go back to a Design View and review the unity check. It should no longer have the ~ in front of it, indicating that it is a final unity value. If the unity value is greater than one, the member has failed and you need to iterate the design process. The closer the unity value is to one the more efficient, but less conservative the member is.

Reporting Design Checks

To create a design report listing the checks performed, double-click on the member in the Design View (this is the same as right click and "Report Selected Member"). You can also right click and "Report Check Summary" which may be preferred for larger models with many members. The Report Wizard can also be used to customize reporting for Design Checks.

Another useful tool in larger models is the Find Tool (F7). This allows you to see unity checks without switching to a report view. Consult the User's Guide for more information on the Find Tool.