VisualAnalysis icon
Upgrade to VisualAnalysis 17.0 today. Here's why.

VisualAnalysis 12.0 Help

VisualAnalysis Tutorials: Concrete Beam Design

Project Description:


This example will use the continuous beam shown below to illustrate the process of designing a concrete beam.

Building the Model

Create the model with a continuous beam consisting of two 25' long, 12" wide by 18" deep concrete (f'c = 5 ksi) members. Select the member, and on the Modify Tab under the Shape heading, select "Standard Parametric" from the drop down menu next to the Source heading. Use the ellipsis button [...] to bring up the Parametric Shape Dialog. Next, create a pin at the left most support (in a 3D Space Frame model you must also restrain the rotation about the x-axis), and restrain displacement of the other two nodes in the y & z-directions. If you need help creating the model please consult the VisualAnalysis User's Guide (Help | Contents).

Modeling Discussion:

Should the beams be designed as one combined member or two separate members? The answer to this question lies in the way the design module is set up. From the diagram below, we see the typical steel layout (see the VisualAnalysis User's Guide (Help | Contents) for more information about the steel layout). It is quite evident that this detailing is laid out for negative moments at the ends and positive moment in the middle. These moments will correspond correctly to our detailing. Had we modeled the two 25' long beams as a combined member, the design module would not accurately call out adequate reinforcement for the moment pattern. For the alternative, consider our model with the first span split into two members (see diagram below).

Diagram Displaying Model with First Span Split

For analysis purposes we could analyze the beam as two members, but for design purposes we need to "combine" members M1 and M2 of the model above using the Model | Combine Member Elements command. If we leave the members as two separate members, the right end of the first member and left end of the second member will have positive moments and we will not be consistent with the steel detailing pattern.

Diagram Displaying Model with First Span Combined

Loading

Create the following service load cases:

Dead Loads: downward 2 kips/ft on both spans (include self weight)

Live Load: downward 3 kips/ft on both spans

Next, select ASCE7-10 LRFD from the Load Case Manager to include these load combinations in the analysis. Information on applying loads and selecting factored combinations is available in the VisualAnalysis User's Guide (Help | Contents).


Design Group Parameters

Now, switch to Design View. VisualAnalysis automatically creates design groups for you. The design parameters are controlled completely through the Project Manager. Select the member in the design view and click on the Modify tab of the Project Manager to begin editing the design parameters.

Concrete Parameters:

The "Concrete Beam" parameters are the first parameters available for editing in the Project Manager. For this example, leave these general parameters unchanged.

Design Parameters:

The "Beam" parameters are next in the Modify tab. The beam will be designed as a rectangular section.

For the purposes of this example, we will assume that 12" columns frame in at both the start and end of the beam. With this in mind, specify the Column Width at Start and Column Width at End both as 12". This allows the software to calculate capacity corresponding to the moment/shear demand at the appropriate locations.

Width and Depth can be constrained under the Design heading. Set the Min/Max Width to 12"/24", and the Min/Max Depth to 18"/36" respectively. Set both the width and depth increment to 2 in. These settings let the design software know that you want it to work through cross sections two inches at a time (i.e. Try a 12"x18"; then a 12"x20"; then 14"x18"; then a 14"x20"; then a 14"x22").

Leave the High Seismic Risk option unchecked. See the VisualAnalysis User's Guide for more information on this option and when you might want to use it.

Beam Options:

The basic material properties for the beam are controlled using these parameters. Make sure F'c is set to 5000 psi (you must change this setting while in the Model View). Set both cover values to 1.5 in. Also make sure the Reinforcing Steel Fy values are both set to 60,000 psi.

Stirrup Parameters:

The next set of parameters is the Stirrups Parameters. Set the bar size to #4 to indicate we want to use #4 stirrups. Leave the "# vertical legs" set to 2. Leave the Symmetrical Spacing option unchecked as well. This option would require the stirrups to be spaced symmetrically about the beam centerline.

Analyzing the Structure

When you are designing members, the design process cannot take place until the model has been analyzed. For this example let's use First Order Analysis Results (Modify Tab of the Project Manager while in the Model View screen). Analyze using the Analyze | Analyze Now menu item.

Designing the Member

Once the analysis is complete, select the Design View tab. Design checks are performed using the specified member size. VisualAnalysis will attempt to find a reinforcement pattern and the given cross section dimensions. In this case, a unity value of "2" is reported. Right Click on the member and select "Report Selected Members". The report will give you information as to why the member does not pass. Here, the member section is too small, and the area of steel required will not meet ACI requirements (maximum reinforcement ratio's etc).

If the section we initially chose was larger, the software may have been able find a reinforcement pattern to work. A unity value will be reported based on the reinforcement area that satisfies code requirements, but may not consist of rebar sizes you prefer to use. We will revisit this issues and how to modify rebar patterns in the next section.

Now, it may be of use to allow the design software to select a section that will meet strength requirements rather than using a trial and error iterative process. Choose Design | Design Selected Group (or select the ellipsis button [...] next to Design election in the Modify Tab). This will pop up the Concrete Beam Design Selection dialog. Here you can make a selection if one of these meets your requirements. Select the 20"Wx26"H for this example.

Synchronizing Design Change

After accepting the design, the unity value that appears in the design view should have a ~ in front of it indicating that it is a preliminary value based on the analysis results with the original 12"x18" member in place. To get the updated (actual) unity value you must synchronize the design changes.

To synchronize the design changes, select Design | Synchronize Design Changes. Next, you will be prompted to re-analyze, select "Yes", and when it finishes re-analyzing go back to a Design View and review the unity check. It should no longer have the ~ in front of it, indicating that it is a final unity value. If the unity value is greater than one, the member has failed and you need to iterate the design process. The closer the unity value is to one the more efficient, but less conservative the member is.

If you would like to adjust the reinforcement sizes used in the design, click on the ellipses button [...] next to the "Adjust Rebar" item on the Modify Tab. Once the rebar is modified to your preference, verify the Rebar Status in the lower right corner of the dialog, and select "Ok". Your unity check may or may not be affected (in this case strong shear is controlling).



Reporting Design Checks

To create a design report listing the checks performed, double-click on the member in the Design View (this is the same as right click and "Report Selected Member" that we previously did). You can also right click and "Report Check Summary" which may be preferred for larger models with many members. The Report Wizard can also be used to customize reporting for Design Checks.

Another useful tool in larger models is the Find Tool (F7). This allows you to see unity checks without switching to a report view. Consult the User's Guide for more information on the Find Tool.