VisualAnalysis icon
Upgrade to VisualAnalysis 17.0 today. Here's why.

VisualAnalysis 12.0 Help

VisualAnalysis Tutorials: Getting Results

Project Description:

The simple plane frame shown below will be used in this example to demonstrate the various analysis types that are available in VisualAnalysis. These analysis types include standard 1st order, P-Delta, dynamic modal, and dynamic response.

Version Note: This tutorial was created using a prior version of VisualAnalysis. Minor changes to the software may have occurred including new features and graphics updates. The appearance of dialog boxes and the Project Manager may be altered slightly. () or the User's Guide () if steps do not appear correct.

Modeling the Structure

Start a new model using File | New or with the VisualAnalysis Startup Wizard. Make sure the project is a "Plane Frame" (Modify Tab | Structure Type). Set the unit style to USA K-ft (Drop down Menu on the Command Bar), and name the project "Getting Results" (Modify Tab - Title).

Draw the frame as shown above using click+drag. (Column length=15ft, beam length=25ft.)

Specify the columns as W14x53, A992 Gr. 50. (Modify Tab | Shape - Name)

Specify the beams as W21x55, A992 Gr. 50. (Modify Tab | Shape - Name)

Fix the bottom of both columns. (Modify Tab | Support - Type)

Loading the Structure

Select the Live Loads (L) service case from the Command Bar and add a -1.5 k/ft uniform live load to the beam. Next, select the seismic load service case (E+X) on the Command Bar and add a 10 kip nodal load at the left node as shown above.

Now use Load | Load Case Manager to create a new custom combination case. Choose the "Create Factored Combination" button. Name the Combination "1.2D + 0.5L + 1.0E". Specify factors of 1.2 for the Dead loads, 0.5 for the Live loads, and 1.0 for the Seismic +X loads. Note that you should be careful when using custom load combinations. If loads are placed in service cases that have a zero load factor, they will not be considered in the analysis and design.

Analysis and Results

Before running an analysis, you should always select Analyze | Check Model for Errors. This will check your model for any potential errors before you start the analysis. You should receive a message indicating that no problems were found.

1st Order versus 2nd Order Results


You now need to specify what type of analysis you would like to run. In the Project Manager, select "P-Delta" under Modify | Analysis | Static Method. This will cause a 1st and 2nd order analysis to be performed. Next, select Analyze | Advanced Analysis Options from the Main Menu. Make sure the check box for "Calculate dynamic mode shapes" is unchecked. Click OK and run an analysis using Ctrl + A or Analyze | Now. Let's compare the 1st order results with the 2nd order (P-Delta) results. On the Filter tab of the Project Manager, make sure the following boxes are checked: "Displaced" and "Reactions". You can also choose to Show "Picture View" and Hide "Wire-Frame Overlay" so your model looks like that shown in the tutorial. Also, select "Mz, moment" in the drop down list Member Results, "Colors" under Graphics, check "Extreme Labels".

First Order results with bending moment displayed

The type of result displayed is controlled in the Project Manager under Filter | Results Display | Analysis Type. Change the Analysis Type to "First Order". Note the numerical values displayed. Leaving the graphical display the same, change the Analysis Type to "P-Delta". The bending moments will all slightly increase. (You may have to toggle back and forth to catch the difference.) In this case the amount of variation is fairly small, but with different member size and stiffness this effect could become significant.

For more information about P-Delta analysis refer to the VisualAnalysis User's Guide or reference structural texts on the subject.

Dynamic Results

Now let's look at the dynamic results in VisualAnalysis. The options for dynamic results include mode shapes and response analysis. The mode shapes extract the fundamental frequencies at which the structure can be excited. Theoretically there is a mode shape for each degree of freedom of the structure. Typically only the first few are used until sufficient modal participation is achieved as specified in the building codes.

Careful attention should be given to ensure that the mass and stiffness of the structure are modeled properly. These parameters can have significant effects on the results that VisualAnalysis yields. The Analyze | Advance Analysis Options allows you to include mass from a load case or combination. You can also lumped mass at individual nodes to more accurately model the mass distribution in your structure. It is a good idea to split your members up in to multiple pieces when performing a dynamic analysis because the mass of elements is concentrated at the nodes. This results in a "smoother" mass distribution and will give you much better mode shapes and natural frequency values.

To obtain dynamic results, we first need to modify our model slightly. Start by moving back into the Model View and splitting the beam into 10 equal pieces using Model | Split Member (this is easier seen with the "Default Model" option turned on under the Quick Views drop-box). We will assume that we have a piece of machinery weighing approximately 3000 lbs sitting on the right hand side of the beam. Select the three right hand nodes and specify the translational mass as 1 kip for each node under the Modify tab of the Project Manager in the Mass heading.

Alternatively, we could have also created a load case to simulate the machinery's mass and included that load case (or combination) on the Advanced Analysis | Options page.

Now split each of the columns into 10 equal pieces just like we did for the beam. Under Analyze | Advanced Analysis Options, check the box "Calculate dynamic mode shapes" and change the number of mode shapes to 6. If you now run an analysis you should get six different mode shapes, the first of which is shown on the following page. Note the mass labels shown for the nodes assigned a 1 kip mass. This filter is found in the Project Manager | Node Details.


Mode Shape #1

We now need to create a dynamic response case in order to perform a response analysis. Go to Load | Load Case Manager and select the Dynamic Tab. At the bottom of the menu select "Create Response." Title the new case "Seismic X," specify the Design spectra as UBC S1 Soil, and enter the direction multipliers as shown below.


New Dynamic Response Case

Now go back to Analyze | Advanced Analysis Options, and check the CQC Method and specify the damping as 5%. Please refer to the VisualAnalysis User's Guide or a structural dynamics text for more information about the CQC and SRSS methods of combining modal response. Also note that the CQC method is a variation of the SRSS method. The SRSS method works well as long as the modes are NOT closely spaced. If the modes are "closely" spaced the CQC method provides a better result for total response.


Now analyze the structure. We should now have results for our six mode shapes as well as our dynamic response case. Most building codes require that a dynamic response analysis include a certain minimum percentage of participating mass in the response analysis. This is something we can easily check using the Dynamic Analysis Summary report. To create this report, go to Report | Report Wizard. Under the Available Items select Dynamic Analysis Summary, click the "In" button, and then click "Next".

Add Dynamic Analysis Summary to the Reported Items list.


On the next dialog box, leave the default of Report all load cases and click Finish. You should now have a report like the one shown below.

In this case, the X direction is the one we are concerned with and our report tells us we have a modal mass participation in the X direction of about 90%. Most building codes require at least 90% so we have enough mode shapes. If this percentage were too small you would probably need to analyze with more mode shapes.


Another useful report is the quick report available for the response load case. In a result view, change to "Seismic X" on the result case drop menu. Now right-click and select "Report Complete Model" from the context menu. This will bring up a report that includes the Dynamic Analysis Summary, Dynamic Response Cases, Nodal Displacements, Nodal Reactions, and Member Internal Forces. The option "Report Complete Model" is always available in a result view and the report will automatically include the items relevant to the e type of results you are viewing.

Moment Mz color distribution from a dynamic response case.

This point marks the end of the tutorial "Getting Results". You now have performed second order and dynamic analysis on a model. Congratulations!