VisualAnalysis icon
Upgrade to VisualAnalysis 17.0 today. Here's why.

VisualAnalysis 12.0 Help

Editing Text Reports

Any open report may be customized to better present the information you need to see. 

Changing Column Widths

To change the width of a column, simply use your mouse to drag the dotted line separating columns.  Row heights can be adjusted in the same manner.

Add or Remove Items

To change the contents of a report, use the Modify tab and click the Contents [...] button. The Report Includes dialog has two lists. The left list shows items (tables, summaries, or graphics) that are available to include in the report, based on your current project, while the right list shows items that are already included.

Use these two lists to add or remove items from the report. You may also reorder the items that are included in the report.

In some cases you may wish to include a table more than once. You might use the first instance to show some of the columns in the table, and the second to show other columns.

Change Table Properties

To modify an individual table or summary, Double-Click on the section you wish to modify. The Table Properties dialog will open. Add or remove columns from the table in the same way you add or remove items from the report using the In and Out arrow buttons.  To change the order of the items reported, use the Up or Down arrow button. The Result Table Options tab is available for some tables with additional options for displaying or filtering results.

Units in a report are controlled by the project settings in the drop menu of the status bar.

Sorting Tables

You can sort any table in a report by re-ordering the columns. Simply Double-Click on the table in the Report View. Tables sort based on the first column, then the second, then the third, etc. until the lines are different or the end of the line is reached. This provides a quick way to organize tables differently than the default—especially result tables where you may want to organize a table by member element, by result case, by member offset, or by bending moment magnitude.

There is also a preference setting under Edit | Preferences on the Reports tab to "Show Results by Load Case". By default result tables are sorted by node, member, plate or spring support (that is the first column), by checking this option you can have result tables automatically place the Result Case first.

Insert a Picture

There are two types of graphics available for reports. Use Report | Report Properties to include a Member (Graphic) Summary or Nodal (Graphic) Summary in your report. These pictures are generated automatically and are not customizable. If they do not serve your purpose, you may insert your own custom image as described below.

You may paste any image from the Windows clipboard. This is a good way to get your current Result View included in a report. Use Edit | Copy when the Result View is active, and then switch to the Report View, position the cursor, and choose Edit | Paste. Once the image is in the report, you may be able to resize it by selecting it and Dragging one of the corners with your mouse.

Filter Report Information

It is easy to create a report that tells you everything about your project all at once. For models of any real size that report would be hundreds of pages long, and nearly worthless. You will want to trim or filter the information in tables by only including the columns that you need, using Report | Table Properties, and by reporting information for selected or named objects only, using the Modify tab in Project Manager.

Result tables in particular can show just the extreme rows. You can also report just selected load cases or selected result cases.

Name Filters can be very powerful for filtering elements or nodes.  Detailed syntax is described on the Viewing page, because name filters are used for graphics as well as reports.

Add Text to a Report

You may type custom text inside a Report View or replace text that is already in the report. Use the mouse to position the cursor or select text by Dragging. Headers and footers are included and somewhat modifiable through Edit | Preferences, but you may not type directly in headers or footers. Be careful when adding text to reports, if the report is caused to regenerate, your text will be lost. We recommend that you save a report to a file and use a word processor for any significant additions or modification you wish to make manually.

Deleting Selected Text

To delete any portion of a report highlight a selection and press the Delete key. You may not delete the portion of the first section containing the project name and your name and company information. Some of this information may be changed through using project notes. Currently, Edit | Undo does not work for manual deletion in a Report View.