VisualAnalysis icon
Upgrade to VisualAnalysis 17.0 today. Here's why.

VisualAnalysis 12.0 Help

Editing Models

Name Objects

Model objects are given default names when they are created. For example, members that are orientated horizontally in the x-direction are labeled with the prefix BmX-and members that are orientated vertically are labeled with the prefix COL-.

You should provide your own descriptive names to help you find, filter, and sort members of your model. Both the Filter tab in Project Manager and the Find Tool allow you to filter any visible or listed items by their name prefix.

To name a single object (node, member, plate, or spring), select it in the Model View and use the Modify tab of Project Manager to type in a new name. To rename a group of objects use Model | Rename. Although this may take a little extra time initially, it can really save time later by making elements easier to view, edit, and report.

Rename Objects

The Model | Rename command allows you to rename all objects or selected objects of a single type in one step. The command takes a name prefix, a starting number, and an increment number. You can also specify a directional ordering for the renaming process.

This command can fail if there are already objects with the new name. VisualAnalysis requires that objects of the same type must have unique names.

Move the Model

This command actually changes the coordinates of your model, not just your view of the model! (Panning the view allows you to look at a different portion of the model in the window.)

To move the entire model or a selected portion of the model, use Model | Move. This command will move nodes (and anything attached to them) specific distances in the global X, Y, or Z coordinate system.

Move Nodes

To move nodes and anything attached to them, select the nodes to move. Use the Modify tab in Project Manager and enter a move distance for the X, Y, or Z direction. At present, there is no support for moving nodes in polar or spherical coordinate directions. The Clipboard Exchange tool provides another powerful option for moving nodes in a spreadsheet.

Align Nodes

You may align a group of nodes to a common X, Y, or Z coordinate. Select the nodes and then enter a new coordinate value through the Modify tab in Project Manager. If you need to align nodes along an arbitrary line, you can do that by drawing a member and splitting it into multiple pieces. Then delete the member elements if you do not need them.

Copy & Paste

You can select model objects (and loads) and use Edit | Copy, and then Edit | Paste to generate multiple copies in either a rectangular or polar fashion.  A Generate Copies wizard is presented when you choose the Paste command to guide you through the process. Sometimes there is a simpler more direct paste approach in the Context Menu (right-click), especially when pasting loads from one element to another.

Rotate the Model

This command actually changes the coordinates of your model, not just rotating your view of the model!

You may rotate all or selected portions of the model about any arbitrary point and any arbitrary axis of rotation. Select the portion of the model to rotate and use Model | Rotate. You should note that member orientations are partially defined by the location of the member relative to the global Y-axis. As you rotate the model, you may also be rotating members within the model as well as loads, end releases, and results that depend on the orientation of local coordinates.

Combine Members

This command combines individual member elements into one continuous member externally, while retaining the complete and accurate FEA model of elements internally. Combined members can simplify your view of the model, make the design checks a bit smarter, and also reduce your report sizes.

For finite element analysis it is necessary to split continuous beams, columns, or other structural components into multiple elements because there must be a node at every intersection. VisualAnalysis allows you to re-combine these elements into a single "Combined Member" for easier management and reporting, in fact it will attempt to do so automatically as you construct models. You may also manually combine member elements: select a straight 'chain' of members and choose Model | Combine Members

This feature is powerful and convenient but comes with some drawbacks and limitations. Certain features of members are lost or modified when they are combined: taper definitions, end-releases, member offsets, etc. The 'first' member in the chain will define the shape and material properties for all the members when combined. End connections are defined by the first and last members in the chain. The feature does not yet support curved or bent members. Loads are 'converted' during the combine and split processing of members, and small round-off errors may happen with respect to offset locations.

The combined member feature now allows you to revert back to the original member chain at any time. Once a group of member elements is marked as combined, you can go back to the individual elements at any time using Model | Split Combined Members.

Members are automatically split when drawing. In a frame model type, if you draw a new member that crosses an existing member or members, the existing member or members are automatically combined back into a single piece. (In a truss, combined members are not supported because you need hinges (moment releases) at each joint.)

If you hold the 'Alt' key on the keyboard when you draw a member, it will not be split and it will not cause splits in other existing members. If the end points of the new member fall on existing members, these members will automatically split. If you don't like this behavior, go to Edit | Preferences, the Desktop tab, and check the box to "Always ask to split or combine".

Advanced Editing: You are allowed to edit the location of both interior and exterior nodes that belong to continuous members. Use this feature with caution! If the nodes don't line up, the model may still analyze producing erroneous results. The project manager may be of considerable help when editing nodal locations. Exact values can be entered for each nodal coordinate. If you use the project manager to edit the location of a continuous member's end node, the interior nodes are brought with automatically. This is not the case if you use one of the other methods for moving a node.

Split Members

This command breaks a member element into multiple pieces, inserting nodes as necessary. To connect something to a member, you need to split the member to get a node at the connection point. Beams framing into a girder or a shear wall modeled as a plate mesh connecting to a column are good examples in which the Split Members option should be used.  Nodes are created automatically and member elements are renamed according to the name of the member getting split. For example, member BmX1 may become members BmX1-1 and BmX1-2.  Sometimes nodes can become disconnected to member elements, even though they lie at a coordinate that coincides with the member element.  This can occur when opening models created in different VisualAnalysis versions or other supported file formats.  It can become tedious to manually associate these nodes with the members that cross them.  VisualAnalysis  can automatically resolve these issues using the Fix Disconnected Nodes option in the Split Member dialog.

Split Plates

Use this feature to break plate elements into smaller pieces. Plates are approximate elements. You will often need to refine your model by using smaller plates. This is done by the plates of interest and using Model | Split Plate. Newly created plates are given names based on the original plate.

Internal nodes are created automatically and you have the option to split members that lie along plate boundaries. Normally, you should split members to retain the continuous connection between the two types of elements. 

Reverse Local Axes

Model | Reverse Local Axes has the effect of changing the direction of the local coordinate system for the element. This command can be applied to member and plate elements. Local coordinate directions will affect local loads, member end releases, possibly member orientation, and local results.

Move a Member in the Model

Two nodes define a member location. To move a member, while retaining its same connections to the model, simply move the nodes. Select the node and use the Modify tab of Project Manager to change its coordinates. This will also affect all other elements connected to the node.

To change where in the model a member is connected, you should change the member's start node or end node to be a different node. Select the member and use the Modify tab of Project Manager to change its nodes.

Change a Member's Length

The distance between its two nodes defines a member's length. To lengthen or shorten a member, simply move one of the end nodes. Select the node and use the Modify tab of Project Manager to change its coordinates. This will also affect all other elements connected to the node.

Change a Plate's Size

Plate size is defined by the locations of the nodes, to change the size of a plate element, move one or more of these nodes.