VisualAnalysis icon
Upgrade to VisualAnalysis 17.0 today. Here's why.

VisualAnalysis 12.0 Help

Areas

Introduction

Areas represent a meta-level finite element object. Areas are useful for separating the definition of loads from the definition of low-level member or plate elements, which may change over the course of modeling. They provide support for distributing those loads to elements and allow you to generate plate element meshes to represent actual structural floors, walls, or roof systems. 

Area Details

Advanced Level Features

Creating Areas

Areas are created by sketching them in the Model View. Select the Draw Areas mode from the toolbar, Model menu, or Filter tab in Project Manager. Sketch the area just like you would a plate element except that you can have any number of vertices (Click & drag to define the first edge, then click subsequent points (either grid points or existing nodes) to define subsequent edges. To close off the area, click on the original point. 

Area Local Coordinates

Areas have a local coordinate system that is defined by the first two vertices you sketch, just like a plate element! The Normal direction is the perpendicular (or local z) direction that forms a right-handed coordinate system. The sketch below shows how the local x lines up with the first two "nodes" or vertices. There is no way to reverse the normal direction of an existing area, so you should be careful when constructing similar areas to define them with their normal-axes aligned, this will ensure that similar loads are in the same direction.

You may create area vertices at any grid point. For any area vertex, there does not need to be a node (or elements) in your model near this point although normally your areas will align with your model. Sometimes they may extend beyond the model or lie interior to your model. You may also create "skewed" direction areas that align with a sloped roof or a building wall; they need not be aligned parallel to a global axis.

Areas are defined by vertices and not nodes. Vertices may be located at the same place as a node in your model, but do not depend on that node or follow that node if it is moved. You create vertices automatically when you sketch areas, but nodes are not created in this fashion. If you wish to have a node in the same location as a vertex, you may right-click on the vertex to Create Node at Vertex Location. There is no way, currently, to tie the vertex locations to the node locations, so if your nodes need to move, you will need to move your areas separately.

Areas may be selected and deleted just like any other model object.

Areas have no mass, no stiffness, and offer no constraints or support in your model. Areas are, in fact, not part of the finite element model that gets analyzed, but a higher-level representation of a floor, wall, or roof system in your model used primarily for loading the actual elements in your model. It does not make any sense to create an area without creating member or plate elements for the structural model. Your model must be complete and stable--independently of any areas that you define. You must also ensure that a valid area is created with area edges that do not cross. Areas should not "overlap" each other in the same plane as this could lead to undefined behavior in the software. VisualAnalysis will normally prevent this from happening, but you should know just in case you slip past our defenses!

Generating Areas

Use the Model | Create Areas Automatically to search through your model for good locations for areas. In a typical rectangular building model you would obtain areas for the four exterior walls, and one for each floor plan. The areas generated may not be perfect (and indeed your exterior areas will likely not extend to your base nodes as there were no bounding members between them), so you may need to adjust them, or remove ones you do not want.

A more refined approach is available. Select three, four, or more nodes to define the "corners" of a new area and use the Model | Create Area through Selected command. This will generate a single area in the plane defined by your selected nodes.

Modifying Area Locations

Areas are defined by vertices, not nodes, and therefore do not automatically "track" movements or changes in your structural model. You can use the Filter tab to display Area Vertices--and you may wish to turn off other items so they are easier to work with. You should normally define areas after your model configuration has been fairly well determined! If you move nodes around, your areas may need some adjustment. 

To move an area skewed in space, you'll need to select all the vertices and move them simultaneously. In situations where you have multiple adjacent areas, moving the vertices (and keeping areas planar) may simply not be possible, and you may need to delete the area and redraw it.

Ways to Modify Areas:

1. Move an Area (in X, Y, or Z)

With an area selected, the Modify tab of Project Manager allows you to change the location of the entire area either in a global direction, or for skewed areas you can also move the area in a local direction.

2. Edit Vertices

You can select vertices of an area to contort or reposition them within the plane of the area. The Modify tab allows you to edit the coordinates. You need to Filter On the area vertices, and may need to Filter Off the nodes, to enable vertex selection and editing. 

3. Insert a Vertex (Change the Shape)

You can insert additional vertices one at a time. Select an area edge and choose Split Boundary from the Model View's context menu. A vertex will be inserted along the area edge which you can edit to change the shape of the area.

4. Delete the Area and Redraw it!

You may, in some instances, need to delete the area and re-create it, though this action will force you to redefine all the loads on the area.

Defining Holes & Corridors

Holes are sub-areas within other areas that do not receive loads. Corridors are sub-areas that can receive higher loads, such as for IBC / ASCE 7 load requirements. You may define these items by sketching areas within an existing area. If you draw such an area you will receive a prompt that allows you to choose which type of area you are creating.

Loading Areas

One of the primary reasons for using areas is to create loads that are independent of your actual model and are to simplify load application as area loads are automatically distributed to model elements based on tributary areas and span directions. The area allows you to define the load-span direction as either one-way (e.g. metal deck) or two-way (e.g. concrete slab). To load an area, select it in the Model View, Right-Click to find the Apply Area Load command. See Static Loads for more details about area load options.

Area Loads apply only to objects that lie within the boundary and plane of an area. There is no such thing as an area "offset". Loads will not project onto members or plates that are not in the plane. If you move your model out-from-under an area, then the loads may not get applied to anything at all. You can use the Check Model for Errors command to check area loads, and you can use the report item: Area Loads: Generated Loads to see load generated on Member Elements.

Span Direction

Because loads are generally distributed in a one-way or two-way fashion based on the structure itself (e.g. a concrete slab distributes two-way, a corrugated metal deck is essentially one-way), the span direction option for loads is defined within the area. This makes it easier and simpler to apply area loads in many different load cases. A one-way span direction may be global or specified a line between any two vertices in the area definition. The direction is clearly shown in the Model View. Load distribution to member elements is aligned with the local axes of the Area, there is no way to skew the distribution from the one-way or two-way orientations shown on the area.

Exclude Bracing

There is an option on the area to exclude some members from receiving loads. This option refers to members in the plane of the area whose Framing Type is set to Bracing. In order for braces to be excluded from the loads you must turn on this option and specify each member's framing type appropriately. By default, all members will be loaded.

Validating Area Loads

Area pressure loads on plates are distributed directly to plate elements. If you use this option, there must be plates in the plane of the area. If plates are missing from parts of the area, those loads are simply "ignored" or lost.

Area pressure loads distributed to members are generated using a numerical integration process which will result (behind the scenes) in many point loads on member elements. These loads are consolidated into uniform or linear loads for good performance and accuracy. You can "display" these loads using the Filter, Load Details, Generated Loads. This is useful to insure that you got the span-direction set correctly. Keep in mind that member loads are not drawn to scale so what may look like a "severe" linear load may actually be nearly uniform in magnitude!

To verify the total load generated for area loads, you can use the report table item "Area Loads: Generated Loads" to report the sum total of plate or member loads created for each area load. (You can multiply the pressure value appled by the surface-area of the Area object to compute what the total load should be for uniform loads. For linear loads you'll have to to a bit more math, especially if the Area shape is not rectangular.)

Side Loads

Requires: Advanced Level

If the Auto-Mesh feature is enabled for an area, you may also apply Side Loads, which are simply distributed to meshed nodes along this edge of the plate mesh as nodal loads. Select the side and right-click to apply a load to that side. If only a portion of an area's edge needs a load you could use multiple areas or you can split the side. Use the Filter tab to hide or display area sides.

Requires: Advanced Level

Automatic Meshed Plates

Areas have no stiffness, so to represent a floor or wall you might use plate elements. This can be done by simply checking a box on the Area and defining the plate thickness and material. Areas are meshed in the background, it may take a minute or so for changes to appear in your model.

A mesh of plate elements may be generated from the definition of an area and any holes it may contain. Existing nodes and members within the plane of the area are incorporated into the plate mesh that you generate. If you have manually created any plate elements within the area, then auto-meshing will not work.

Automatically created plate meshes are managed by the system so that you can easily mesh and re-mesh areas with different settings and to accommodate other model changes (like member elements passing through areas). You may convert the plate elements into manual plates should you wish to take control of the mesh, but then you will lose automatic management features.

Controlling Plate-Mesh Count

The total number of meshed-plates created for a model, is loosely controlled by the Auto. Mesh Factor in the Project Settings. Increasing this number will cause more plates to be generated. The number of plates generated for an area is system-controlled, and is a function of the size of the area, the total number of areas in the project, the number of boundary or 'constraint' points within the area and the setting in Project Settings. The more areas and other elements you have in a model, the less impact the Auto-Mesh Factor will have, more plates will be required for connectivity and alignment reasons.

New! You may also request a specific Element Count on each area (using the Override Count option) to have more control over how plate meshes are refined. Strategic generation of plates cna improve your performance and also give you more accurate results. See plate meshing information for more details about convergence.

Requires: Advanced Level

Area Side Support

The edges or sides of meshed Areas may be supported similar to nodes.  Side supports are defined by selecting one of the Area sides in the Model View and selecting from the available constraints in the Support heading found on the Modify Tab of the Project Manager.  (Note: Area sides are not visible or selectable on areas that are not meshed.)

Side supports simply support all meshed nodes along that boundary. These are automatically updated if the area is remeshed.  The ability to defining side support conditions for Areas is critical to obtaining accurate Area Results for a particular model configuration.

Splitting Area Sides

You may split the side of an area, which inserts a new vertex at its mid-point. Right-click on the side and chooseYou can then move this vertex along the edge to change the relative side lengths. Spliting area sides, or modifying area vertices may require you to redefine your edge supports.

Requires: Advanced Level

Area Results

Areas are not true model objects (lacking stiffness) and as such have no results; however, if the Automatic Meshed Plates feature is selected, Areas are assigned stiffness properties and have self weight based on the selected material and can also have edge or boundary results. 

With unmeshed Areas you can report basic information about your area definitions for documentation purposes and to help you validate area loads and the generated results (and nodal and element forces created by them). 

With Automatic Meshed Plates enabled, plates results are available, and results can be viewed the as they are with manual Plate Elements

Area Side Results

Area Side Results are also available and can be very useful for designing shear walls and diaphragms when total or average results are easier to work with than individual plate element results.  Area   boundary results are available as Average, Detailed, or Resultant forces calculated across the Area boundary.  Results are available for In-plane Shear (V), In-plane Axial (P), Out-of-Plane Shear (V'), Out-of-Plane Moment (M'), and Overturning Moment (Mot) ( Area Resultant results only).  Results can be reported using the Report Wizard, displayed in the Find Tool and displayed graphically in the Result View via settings found in the Project Manger on the Results tab).  Local axes and sign convention depend on the direction that Areas were drawn.  Coordinates defining the Area boundary results are reported under the Side Direction/Ends heading.  Selecting an Area boundary you wish to view will highlight the results in the Find Tool (you may need to scroll up or down to see the selected boundary).  Selecting an item in the Find Tool results list will highlight the item in the Result View.  A legend can also be viewed using the Filter Tab.