VisualAnalysis icon
Upgrade to VisualAnalysis 17.0 today. Here's why.

VisualAnalysis 12.0 Help

Viewing

Window Types

VisualAnalysis can show you many different views of your model, loads, analysis results, and design results. You may choose to work with one main window or you may prefer to have many windows open and available.  The commands described in this section will provide useful tips for helping you manage these windows and to control the content each view provides. Windows are managed using the Window menu commands.

 Primary "Tabbed" Windows

Supplementary Windows

Dialog Boxes

Dialog boxes are distinguished from windows because they are generally "modal", that is, you must close the window before you can do anything else. Dialogs almost always have OK and Cancel buttons, sometimes they simply have a Close button. Closing a dialog box with the X in the upper-right corner is the same as "Cancel". Dialog boxes are used throughout VisualAnalysis for collecting various pieces of information, or in some cases presenting you with some information.

Determine What is Visible in a View

The Filter tab in Project Manager lets you control what is shown in the active view. Check or clear boxes to toggle objects or labels. There are toolbar buttons available for toggling major model objects: nodes, members, plates, spring supports, loads, and the sketch grid.  Use the Shift key to show "just nodes", or "just members" when clicking on the toggle buttons. It is useful to turn off objects when you are not working with them. For example, it is easier to select and edit plate elements if you first hide nodes.

Picture View: Use this filter option to turn on or off a 'rendered' view to show the actual shapes and orientations of member elements and the to-scale thickness of plate elements.

New in version 10.0Hightlight Report: Use this filter option to provide an alternate way of showing the selected state of elements and loads, primarily in a Model View. This mode lets you focus attention on the selected items, while 'ghosting' or fading the rest of the model (showing context). The mode works in conjunction with most other filtering and viewing features. The purpose of this mode is to create a printed graphical report, but you may prefer it to the 'normal' graphics.

You can show or hide objects based on the geometry of your model. See Cut Views & Volumes.

Rotating the View

The easiest way to rotate your view of the model is to click on the "Cube" in the lower-left corner. You can click on a face, edge, or corner to orient the model.  For custom orientations, you can hold down the Ctrl key and the mouse-wheel (middle button) and drag the mouse around!  See mouse commands for more details.

If you are using a vertical axis different than the default "Y", be sure to set this in the Project Settings, otherwise rotation can be a bit frustrating.

Click on the Rotation Cube to Rotate the View Use the Toolbar Rotation buttons to rotate the view

Rotate the View a Small Amount

Use the View | Rotate Command, or their associated toolbar buttons, to "nudge" the view a little. These commands rotate in a positive or direction about one of the global axes, you can hold the Shift key to reverse the direction of the rotation as you use the commands.  Use Ctrl+Arrow keys and to rotate the model about the X and Y axes, respectively. The nudge angle is customizable under Edit | Preferences. under the Filter section.

If you have a single node, or element selected, VisualAnalysis will try to rotate about that item such that it remains in view. For general rotation, make sure either nothing is selected or a bunch of items are selected.

Also see the Mouse Commands, for ways to rotate your model!

Pan the View

Hold the Shift key and use your mouse wheel held down like a button to pan the view left, right, up, or down.  You can use Shift+Arrow keys as well. See Mouse Commands for configuring your mouse-wheel button.

Zoom In or Out

Now with Mouse Wheel support, just scroll your mouse wheel to zoom in or out of the model. Note that the model will zoom in or out at the location the mouse is at. For example, if you wanted to zoom in on a particular node, just hold the mouse near that node and scroll the mouse wheel. The rest of the mouse wheel commands are documented in Mouse Commands.

Use View | Zoom | In to bring the model closer or make it larger in the view. View | Zoom | Out will make the model smaller or appear farther away. The View | Zoom | Normal command will restore the default view.  The entire model is made visible in the window. Hold the Shift key and click the Zoom Normal men item to zoom in on the selected model objects.

Zoom a Specific Area

To get a closer view of a specific portion of the model, you can draw a Zoom Box around the area. This portion of the model will be shown in the window. Use View | Zoom | Area to start the procedure, the cursor will change while you define the area. You can click to define the upper left and then click again to define the lower right corner of a box. Alternately you can drag from one corner to the other.

For best results you should try to make the zoom box the same shape as the window. VisualAnalysis will not distort the information in the box to make it fit. Instead, the view will be expanded as necessary to conform to the window dimensions.

The Search feature can also zoom in to the item you find, use Edit | Find.  If you double-click an element in the Find Tool window the graphics will zoom in to show that item.

View a 2D Slice of a 3D Model

Working with 3D models can be very confusing if you try to view the whole model at once. One way to simplify things is to view only a "slice" of the 3D space. To do this, use the Cut Views tab in the Project Manager and choose an Auto-Cut Plane.  Right-click on one of the auto-items to Regenerate Auto-Cut Views all the automatically created views, you might do this if you have changed your model significantly, or if you have changed units.

A cut plane or cut volume acts as a geometric filter. Anything entirely within the cut definition is visible and anything outside of it is not.

VisualAnalysis allows you to turn on multiple cut planes or volumes. You may also save & name any "auto" cut plane and adjust its properties. Cut planes and volumes are used in Named Views to help you quickly return to a particular view of your model.

Clip to Selected

One easy way to define a Cut Volume is to select two or three nodes or elements in your model and choose View | Clip to Selected. This command has the effect of automatically adjusting the Cut Volume settings to show objects in the "plane" of the selected objects. Your cut volume is saved in the Cut Views tab of Project Manager under My Cut Views.  You can Right-Click on a cut view to edit its properties or rename it.

Use this command as a faster and easier way to define a custom cut volume for most typical situations. This command is not available if the selected objects do not define a "box". For example, three collinear points define an infinite number of planes.

Filter by Object Names

A great way to simplify and organize large projects is to use a good naming system for nodes, members, plates and spring supports. You can filter a view to show only objects with certain types of names. Use the Name Filter area under each object type in the Filter tab of Project Manager. Use the Model | Rename command to help you define member specific names in the first place.

A simple name filter might be a single character, "M". Think of this as saying, "Show me all the members whose names begin with a capital letter M."

Name filters are very powerful and you can be very creative in their use. The software will accept a list of name filters and you can also use regular expressions for more control. For example, [^M] is interpreted to mean, "Show me all the members whose names do not begin with a capital letter M."

The following table provides some of the symbols used to control this powerful feature along with some examples. Effective use of name filters requires some forethought when naming objects. Spending the time to setup a good convention right away will save you a lot of time later, especially with larger projects.

Symbol Interpretation
Col Matches any name that begins with 'Col', exactly, case sensitive, such as Col001, Col002.
[^Abc] Negates the name. Matches any items that have names that do NOT start with Abc. This may not be combined with anything else.
A, Bm (OR) Match names beginning with 'A' or 'Bm'

Animate a Result View

Result Views can show the deflected shape and you can animate this view by selecting the View | Animate Result View command when a Result View is active. For static results the animation will help you see where the structure is deflecting. For dynamic results you have the ability to see real-time vibration behavior on top of deflections.

Create, Cascade, Tile, and Close Windows

Most of the time in VisualAnalysis you work with one primary graphic window (with tabs at the bottom). You CAN however open multiple windows using the Window | New Graphic View command and the other Window commands. If you use Window | Cascade you can see if you have multiple windows open and use the [x] button in the upper left corner to close one. Some 'uncommon' VisualAnalysis windows (like influence line graphs) open in this manner rather than in a tab. If you are getting 'strange' graphical behavior in your window, you can 'reset' the graphics by creating a new window, and then closing the original one.

Use Saved (Named) Views

When working with large, complicated models, you will often spend considerable time setting up a good view. VisualAnalysis will save your view types either with the Project or in a Global format for use on future projects. Use the View | Save the Current View command to save the current window type and filters as a named window type. Project specific views also include the zoom level, rotation setting, cut views, and more. You can return to this view by selecting from the Quick Views.. drop-down list in the Command Bar.

An example for saved view might be a Model View of the second floor plan, viewed from the top, with section properties turned on and other labels turned off, and nodes hidden. It may take you a dozen commands to get the view set up, but if you save it, you can get back to it with just a couple clicks.

Sometimes you will return to a previously named view and decide it is not quite right. In this instance, make your changes and then choose View | Update Saved View.

To Delete a previously named view use View | Delete Named Views. Saved views are stored in a data file, see Edit | Preferences, Files for information about accessing this data file, which you could 'share' with another machine.