VisualAnalysis icon
Upgrade to VisualAnalysis 17.0 today. Here's why.

VisualAnalysis 12.0 Help

Directing VisualAnalysis

The Application Layout

Here is the default layout of windows and controls in VisualAnalysis. The major sections of the window are named for easier reference later.

Please note that many of the screen elements can be hidden or moved to create a custom working environment.

The Main Menu

The main menu in VisualAnalysis is the backbone. It is generally not customizable or overly dynamic and will always provide the commands you need. The menu is organized according to standards set by Microsoft guidelines and software to help make it easier for you to use. It is also organized logically for the engineering tasks that you will perform.

Many menu items have Keyboard Shortcuts so that you can access the command without actually locating it in the menu.

Menu items are brief. If you are not quite sure what a menu item does you should look to the Status Bar. The Status Bar normally provides menu hints, which are one-sentence descriptions of commands. If a menu item is disabled, the Status Bar hint changes to tell you why the command is not available.

Context Menus

Most windows in VisualAnalysis provide a right-click Context Menu. This menu provides a relevant subset of the commands in the main menu. Access this menu by using your right (or alternate) mouse button. (We normally think of this as a right-Click, but your mouse may be configured to swap the button behaviors.)

This should be your first choice when looking for a command because the available commands have been reduced to a more meaningful set. The commands in this menu are generally grouped according to their position in the main menu to help you locate them faster.

The Mouse

The mouse is a key component of the VisualAnalysis interface. You will use it extensively to sketch models, select objects, bring up the Context Menu, activate controls, and more.

The mouse becomes even more useful with the addition of mouse wheel support. The commands are documented at the bottom of the table below.

If mouse commands are not working properly, or 'selection' is weird, you probably need to update your video card driver!

To Click the mouse means to press and release a button. To Drag the mouse is to press a button and hold it down while moving the mouse. When you see Shift+ or Ctrl+ this means that you should press and hold the appropriate key on the keyboard as you click or drag the mouse. Here are some of the commands available in most graphic views:

Mouse Operation Description
Click
or Left Click
(Primary Button)
Selects a single item under the mouse cursor. All other items are usually unselected.

Some multiple selection lists allow a single click to toggle the selected item without changing the state of other items, making it easier to select many items.

If the View | Zoom Area command is active this will either start or finish the creation of a "Zoom Box".

Right Click
(Alternate Button)
Open theContext Menu (also called a popup menu). Also used to access "What's This?" help in some situations.
Shift+Click In a graphic view, selects all visible objects of one type.  In a list, selects everything within in a range (Click the first item, the Shift+Click the last item in the range).
Ctrl+Click In a list or in a graphic view, it toggles the selection of the item under the mouse without affecting the selection status of other items.
Shift+Ctrl+Click Selects items of one type with the same Name Prefix as the item clicked on.
Double Click In a Model View or Report View, opens the edit dialog for the object. In a Result View or Design View this will generate a Report View for the object.
In the Find Tool window, double-clicking on an element or node item will cause the graphics to Zoom to that item.
Drag [Drag is defined as holding a button down while moving the mouse.] In a Model View, this can sketch members, plates, cables or area between grid points or existing nodes, depending on the drawing mode. 
Alt+Drag In a Model View you can sketch members or plates without the auto-split & connect feature.  Useful for drawing X-bracing, where you don't want the crossing members to be connected.
Ctrl+Drag Holding down the Ctrl key and dragging will move a node to a new location.  (The coordinates will be shown in the status bar.)
Space+Drag
or
Shift+Drag
In a graphic view, draws a "Selection Box"—anything visible inside the box is selected. Everything else is unselected.  The Space Bar method avoids "select all" issues when your selection box would start on top of model objects, especially plate elements.
Shift+Ctrl+Drag Same as Shift+Drag, but does not change the current selected state of other objects.
Wheel Rotation Zooms in or out of the model at the mouse location.  In a list or text window, it scrolls.
Drag * Pan the model in a Graphic View by with a Click and hold on the wheel button, and dragging the mouse.
Ctrl + Drag Wheel Mouse* Rotates your view of the model in the direction of mouse movement.  This approach allows for an custom rotation of the view.  You may also "Click the Cube" in the lower-left corner of the window on either a face, edge or corner to quickly rotate the model.
Double Click Wheel Mouse* Same as View | Zoom Normal menu command.

*Note: Your mouse must be set up to interpret a wheel click as a Middle-Button, Windows lets you customize mouse commands through the Control Panel, Hardware, Mouse.

Keyboard 'Hot' Keys

Shortcut keystrokes to certain menu or other types of commands. Note that some are not used (yet). Note too that some are context-sensitive, for example if an edit-control is actively accepting keyboard input then the copy, paste, delete and escape commands will apply only within that box.

Keystroke Command Keystroke Command Keystroke Command Keystroke Command
Ctrl+A Analyze | Analyze Now Ctrl+O File | Open Ctrl+1   F1 Help | Help Contents
Ctrl+B Model | Generate Copies Ctrl+P File | Print Ctrl+2 Load | Nodal Load F2 View | Toggle Project Manager
Ctrl+C Edit | Copy Ctrl+Q Report | Quick Report Ctrl+3 Load | Member Load F3 Edit | Repeat
Ctrl+D Model | Create Node Ctrl+R Analyze | Result Validation Ctrl+4 Load | Area Load F4  
Ctrl+E Analyze | Check for Errors Ctrl+S File | Save Ctrl+5 Load | Scale Loads Alt+F4 File | Exit
Ctrl+F Edit | Find Ctrl+T Analyze | Toss Results Ctrl+6   F5 Report | Report Wizard
Ctrl+G View | Toggle Grid Ctrl+U Edit | Project Units Ctrl+7   F6 Previous Graphic View
Ctrl+H Edit | Replace Ctrl+V Edit | Paste Ctrl+8   F7 View | Toggle Find Tool
Ctrl+I View | Grid Manager Ctrl+W Window | Cascade Ctrl+9   F8 Design | Design Group
Ctrl+J View | Highlight Mode Ctrl+X Edit | Cut Ctrl+0   F9 View | Picture View Mode
Ctrl+K View | Cut View for Selected Ctrl+Y Edit | Redo Ctrl+ + View | Zoom In F10  
Ctrl+L

Load | Load Case Manager

Ctrl+Z Edit | Undo Ctrl+ - View | Zoom Out F10  
Ctrl+M Window | Member Graph Del Delete Ctrl+Home View | Zoom Normal F11  
Ctrl+N File | New Esc Cancel Ctrl+Numpad 5 View | Zoom Normal    

 

Keystroke Command
Ctrl+Up/Down Arrow View | Rotate about Horizontal
Ctrl+Left/Right Arrow View | Rotate about Vertical

Shift+Left Arrow

View | Pan Left
Shift + Right Arrow View | Pan Right
Shift + Up Arrow View | Pan Up
Shift + Down Arrow View | Pan Down
Ctrl+Shift+B Model | Mirror Copy
Ctrl+Shift+C Model | Combine Members
Ctrl+Shift+E Model | Extend Members
Ctrl+Shift+R Model | Rename
Ctrl+Shift+S Model | Split Member
Ctrl+Shift+X File | Import DXF
Ctrl+F4 Close active Graphic View
Shift+F6 Next active Graphic View

 

The Toolbars

By default there are two toolbars just under the main menu. These toolbars represent shortcuts to menu items. Hold your mouse over a button for a "Tool Tip", which is usually the name of the command as it appears in the menu. Clicking the button is the same as choosing the equivalent main menu item. The second toolbar changes depending on which window or tab is active. (There is a third toolbar, called the Command Bar, which is attached to the top of the active window.)

The Command Bar

The command bar provides important controls for the active Graphics view including a load case or result case selector, a view orientation list, a named view drop-down, and the current project units setting. The bar also contains a few buttons to access the Load Case Manager, edit the active Load Case, or close a supplementary window.

There is a drop-down list of saved project reports, followed by saved report styles. Simply select one of these to display the report in the Report View.

The Project Manager

The Project Manager provides immediate access to frequent operations in VisualAnalysis. This tool is docked on the left side of the window by default and displays five tabs at the top. If for some reason you do not see the Project Manager press the F2 key or go to View | Show or Hide | Project Manager. You may toggle this window if you need more space to work, and it can be docked on the left or made to float independently—just drag the gripper at the top. You can also drag the side border to make it wider or narrower.

The Create tab is used to draw models fast and create quick reports. It is here that you will find all of the new "generate standard" items.

The Modify tab is used to inspect or modify selected model and load objects, while a Model View is active.

The Filter tab provides many toggle switches and a few other settings to control what and how information is displayed in the active view.

The Grid tab controls the Sketch Grid to help you draw models in a Model View.

The Result tab replaces the Modify tab if a Result View is active. This tab provides key result information for the active load case. Most of this information is also available in reports, but is displayed here for more convenient access as you inspect and verify your results.

The Cut Views tab allows users to work on specific areas of their projects through the use of Auto-Cut Planes and Auto-Cut Volumes. These allow you to view a 2D slice of a 3D model, for example.

The Find Tool

The Find Tool provides a very efficient way to view, select, and edit nodes, members, loads, load cases, design groups and many other aspects of your model. This tool is docked on the bottom of the window by default.  Use F7 or the View menu to open or close this window. Change the start-up location of the Find Tool (shown or hidden) using Edit | Preferences, Desktop.

The Find tool is especially powerful with more complicated projects. The Find tool will also allow you to find, select, edit, and delete objects even if they are not visible in the active window.  If you double-click an element (member, plate, spring) the graphics window can zoom-in to show that element. 

Lists shown in the Find tool may be sorted by clicking on a column header, click again to reverse the order. You may select items just like any list in Windows using the Shift and Ctrl keys to select a range or to toggle individual items. The check boxes provide an alternate way to select items, clicking a check box is similar to holding the Ctrl key.

Auto-Collapse Find Tool Window

The find tool can automatically collapse to a small "toolbar button" to stay out of your way when you don't need it. Locate the tiny "push-pin" icon in the "Title Bar" of the window near the "x" button to close the window. Toggle the push pin icon to enable or disable the auto-collapse behavior.

Help "inside" VisualAnalysis

We design VisualAnalysis to be used without any help or manuals as best we can. However, we understand that it offers many features and capabilities that might not be discovered or fully understood without this documentation. Please make use of the many forms of help available before you contact our support staff.

Help Source Description
Model View Help The right-click menu in any graphic view (context menu) contains an item to help you learn and the purpose and features of the window. For example, mouse and keyboard commands that are specific to the window type are described.
Help | Contents   F1 The full User's Guide is available within the program to search or browse by contents. You may bookmark favorite topics to make them easier to find in the future.
Menu Hints The Status Bar explains why the Main Menu commands are disabled. (Hint: this help only works on Main Menu items, not on toolbar items!)
Message Boxes Message Boxes convey important information, please take the time to notice the title and read the messages carefully. Often times, messages indicate a problem, but they also suggest solutions.
Dialog Hints, Tool Tips Some dialogs or interface items offer hints with pictures or text to indicate the implications of a choice or setting or to more clearly describe what the feature does.
Example Projects Use File | Open Example to find these projects, which may be organized into sub-folders. These projects demonstrate various features of the software.